Задать вопрос
26 декабря, 03:08

Паскаль. В двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь один раз. Нужно написать программу.

+2
Ответы (1)
  1. 26 декабря, 04:14
    0
    Var matrix: array[1 ... 5,1 ... 5] of integer; i, j: integer; sg:=0; sp:=0; begin writeln ('Введите 25 чисел: ') ; for i : = 1 to 5 do for j : = 1 to 5 do read (matrix[i, j]) ; for i : = 1 to 5 do begin for j : = 1 to 5 do write (matrix[i, j], ' ') ; writeln end; for i:=1 to 5 do begin for j: = 1 to 5 do if j=i then sg:=sg+matrix[i, j]; end; for i:=5 downto 1 do begin for j:=1to 5 do if (i+j) = 6 then sp:=sp+matrix[i, j] end; sp:=sp-matrix[3,3]; 1 writeln (sg,' ', sp) ; readln end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. В двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
В двумерном массиве 7 Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали. Определить минимальный элемент главной диагонали (значение и координаты)
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Напишите программу на паскале. В двумерном массиве Z[1 ... 5,1 ... 5]найти наименьший элемент среди элементов вспомогательной (побочной) диагонали
Ответы (1)