Задать вопрос
23 июня, 15:59

Напишите программу на паскале. В двумерном массиве Z[1 ... 5,1 ... 5]найти наименьший элемент среди элементов вспомогательной (побочной) диагонали

+5
Ответы (1)
  1. 23 июня, 19:51
    0
    var Z:array[1 ... 5,1 ... 5] of real;

    i, j: integer;

    min: real;

    begin

    for i : = 1 to 5 do

    for j : = 1 to 5 do

    readln (Z[i, j]) ;

    min : = Z[1,5];

    for i : = 2 to 5 do

    if (min > Z[i, 6-i]) then

    min : = Z[i, 6-i];

    writeln ("Min value is ", min)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на паскале. В двумерном массиве Z[1 ... 5,1 ... 5]найти наименьший элемент среди элементов вспомогательной (побочной) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
В двумерном массиве 7 Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали. Определить минимальный элемент главной диагонали (значение и координаты)
Ответы (1)
Паскаль. В двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь один раз. Нужно написать программу.
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)