Задать вопрос
23 июня, 19:06

Подсчитать количество (сумму) цифр в записи целого неотрицательного числа. (в паскале авс)

+3
Ответы (1)
  1. 23 июня, 20:55
    0
    Program asd;

    var n, a, b:integer;

    begin read (n) ;

    a:=n;

    while a>0 do begin

    b:=a mod 10+b;

    a:=a div 10;

    end;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать количество (сумму) цифр в записи целого неотрицательного числа. (в паскале авс) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
В каком виде будет храниться в компьютере десятичное число 10 (с индексом 10) в формате целого неотрицательного числа и целого числа со знаком?
Ответы (1)
Написать программу подсчитивающую количество цифр целого неотрицательного числа
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)