Задать вопрос
31 марта, 14:01

Написать программу подсчитивающую количество цифр целого неотрицательного числа

+4
Ответы (1)
  1. 31 марта, 17:25
    0
    Var a, k:integer;

    begin

    write ('a (>0) = ') ;

    readln (a) ;

    k:=0;

    while a>0 do

    begin

    k:=k+1;

    a:=a div 10;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    a (>0) = 180653

    k = 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу подсчитивающую количество цифр целого неотрицательного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы