Задать вопрос
31 марта, 20:02

написать программу находящую количество цифр вводимого неотрицательного положительного числа

+2
Ответы (1)
  1. 31 марта, 21:41
    0
    Var

    a, c : integer;

    begin

    readln (a) ;

    c : = 0;

    if (a = 0) then c : = 1

    else

    while a 0 do

    begin

    c : = c + 1;

    a : = a div 10;

    end;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу находящую количество цифр вводимого неотрицательного положительного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители заданного числа
Ответы (1)
Опишите переменные для размещения в них: - пола человека (один символ) ; - целого положительного двузначного числа; -целого положительного трёхзначного числа; -целого положительного четырёхзначного числа; -небольшого вещественного числа;
Ответы (1)
Написать программу подсчитивающую количество цифр целого неотрицательного числа
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Составить программу подсчитывающую количество цифр числа вводимого с клавиатуры
Ответы (1)