Задать вопрос
8 февраля, 15:40

Составить программу определения дня недели по номеру дня года. считая, что 1 января - понедельник.

+4
Ответы (1)
  1. 8 февраля, 18:10
    0
    Var

    n:integer;

    begin

    readln (n) ;

    n:=n mod 7;

    if n=1 then

    writeln ('Понедельник') ;

    if n=2 then

    writeln ('Вторник') ;

    if n=3 then

    writeln ('Среда') ;

    if n=4 then

    writeln ('Четверг') ;

    if n=5 then

    writeln ('Пятница') ;

    if n=6 then

    writeln ('Суббота') ;

    if n=7 then

    writeln ('Восресенье') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу определения дня недели по номеру дня года. считая, что 1 января - понедельник. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в паскале. Дано: Дан порядковый номер дня года (отсчет идет с 1-го января). Требуется вывести номер дня недели этого дня, если 1 января - понедельник.
Ответы (1)
На Паскале помогите написать Дано целое число k (1
Ответы (1)
Помогите написать программу которая по данному натуральному числу от 1 до 2 (номеру месяца) выдает все приходящихся на этот месяц праздничные дни (например, если введено число 1, то; 1 января - новый год, 7 января - Рождество).
Ответы (1)
В Паскале Составьте программу, определяющую название дня недели по его номеру: 1 - Понедельник, 2 - Вторник и т. д. При вводе числа вне диапазона [1 ... 7] программа должна выдать сообщение об ошибке
Ответы (1)
Информатика. 5 Класс. С использованием Оператора выбора. С клавиатуры вводится число - номер дня недели. По номеру дня недели определить и вывести количество уроков в этот день.
Ответы (1)