Задать вопрос
25 апреля, 06:17

На Паскале помогите написать

Дано целое число k (1<=k<=365). Присвоить целочисленной величине

n значение 1,2, ...,6 или 0 в зависимости от того, на какой день

недели (понедельник, вторник, ..., субботу или воскресенье) приходится k-й

день года, в котором 1 января:

а) понедельник

б) вторник

в) d-й день недели (если 1 января-понедельник, то d=1, если вторник - d = 2, ..., если воскресенье d=7).

+1
Ответы (1)
  1. 25 апреля, 10:06
    0
    A) var k, n:integer;

    begin

    read (k) ;

    if k div 7=k/7 then n:=7 else

    if k+1 div 7=k+1/7 then n:=6 else

    if k+2 div 7=k+2/7 then n:=5 else

    if k+3 div 7=k+3/7 then n:=4 else

    if k+4 div 7=k+4/7 then n:=3 else

    if k+5 div 7=k+5/7 then n:=2 else

    if k+6 div 7=k+6/7 then n:=1;

    writeln (n) ;

    end.

    б) var k, n:integer; begin

    read (k) ;

    if k-1 div 7=k-1/7 then n:=7 else

    if k div 7=k/7 then n:=6 else

    if k+1 div 7=k+1/7 then n:=5 else

    if k+2 div 7=k+2/7 then n:=4 else

    if k+3 div 7=k+3/7 then n:=3 else

    if k+4 div 7=k+4/7 then n:=2 else

    if k+5 div 7=k+5/7 then n:=1;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На Паскале помогите написать Дано целое число k (1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано натуральное число n. Вычислить (1+1/12) &#61655; (1+1/22) &#61655; ...&#61655; (1+1/n2). 3. Дано целое число А.
Ответы (1)
Напиши программу. Дано целое число N (N > 0). Найти сумму (N + 1) ^2 + (N + 2) ^2 + ... + (2•N) ^2 Входные данные: ввести целое число N (1
Ответы (1)
1) дано целое число N (больше 0). Найти сумму 1+1/2+1/3 ... 1/N (вещественное число). Входные данные: ввести целое числоN (1
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)