Задать вопрос
26 марта, 01:18

Написать программу в паскале

1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d.

2, дано натуральное число n. Вычислить (1+1/12)  (1+1/22)  ... (1+1/n2).

3. Дано целое число А. Найти произведение целых чисел из промежутка от 1 до А

+5
Ответы (1)
  1. 26 марта, 02:26
    0
    1)

    var a, s, p, n, i:integer;

    begin

    readln (n) ;

    s:=0; p:=1; a:=2;

    for i:=1 to n do begin

    p:=p*a;

    s:=s+a;

    a:=a+3;

    end;

    writeln (s,' 'p) ;

    end.

    2)

    3) var a, p, i:integer;

    begin

    readln (a) ;

    p:=1;

    for i:=1 to a do

    p:=p*i;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены арифметической прогрессии и сумму первых n членов Sn.
Ответы (1)
1. дано действительное число x и целое число n вывести N первых челнов арифметическойкой прогрессии и найти сумму ее первых членов если первый член X а разность 1,12 2.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Задача в паскале абс {ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм. прогрессии и n - число членов прогрессии вывести на экран n первых членов прогрессии например a=4 d=2 n=5 4 6 8 10 12 14}
Ответы (1)
Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии.
Ответы (1)