Задать вопрос
25 марта, 14:14

В Паскале

Составьте программу, определяющую название дня недели по его номеру: 1 - Понедельник, 2 - Вторник и т. д. При вводе числа вне диапазона [1 ... 7] программа должна выдать сообщение об ошибке

+4
Ответы (1)
  1. 25 марта, 16:58
    0
    Var x: byte;

    Begin

    Write (‘ введите число от 1 до 7')

    Readln (x) ;

    Case x of

    1: writeln (‘понедельник’) ;

    2: writeln (‘вторник’) ;

    3: writeln (‘среда’) ;

    4: writeln (‘четверг’) ;

    5: writeln (‘пятница’) ;

    6: writeln (‘суббота’) ;

    7: writeln (‘воскресенье’) ;

    end;

    Readln

    End.

    я не помню как чтоб выдало ошибку ... пили если больше х то ошибка
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В Паскале Составьте программу, определяющую название дня недели по его номеру: 1 - Понедельник, 2 - Вторник и т. д. При вводе числа вне ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
На Паскале помогите написать Дано целое число k (1
Ответы (1)