Задать вопрос
7 августа, 02:31

Напишите программу в паскале. Дано:

Дан порядковый номер дня года (отсчет идет с 1-го января). Требуется вывести номер дня недели этого дня, если 1 января - понедельник. (Запрещено использовать команду if)

При решении этой задачи нельзя использовать любой из видов условной инструкции if.

+1
Ответы (1)
  1. 7 августа, 03:27
    0
    Var n, k:integer;

    begin

    readln (n) ;

    k: = (n-1) mod 7 + 1;

    writeln (k) ;

    end.

    Пример:

    29

    1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в паскале. Дано: Дан порядковый номер дня года (отсчет идет с 1-го января). Требуется вывести номер дня недели этого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Запишите на языке Паскаль программу решения задачи: Объявлен набор в школьную баскетбольную команду. Известен рост каждого из N учеников, желающих попасть в эту команду.
Ответы (1)
За день машина проезжает n километров. Сколько дней нужно, чтобы проехать маршрут длиной m километров? При решении этой задачи нельзя пользоваться условной инструкцией if и циклами. Входные данные Программа получает на вход числа n и m.
Ответы (1)
На Паскале помогите написать Дано целое число k (1
Ответы (1)
Объявлен набор в школьную баскетбольную команду. Известен рост каждого из N учеников, желающих попасть в эту команду. Подсчитайте количество претендентов, имеющих шанс попасть в команду, если рост игрока команды должен быть не менее 170 см.
Ответы (1)