Задать вопрос
25 февраля, 23:19

Даны два положительних числа а и b. не применяя операции деления найти остаток от деления а на b

+3
Ответы (1)
  1. 26 февраля, 00:58
    0
    Uses crt;

    var a, b, c, i:integer;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    i:=1;

    while c
    begin

    c:=b*i;

    i:=i+1;

    end;

    c:=c-b;

    writeln ('остаток (a:b) = ', a-c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два положительних числа а и b. не применяя операции деления найти остаток от деления а на b ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Даны два целых числа A и B (A
Ответы (1)