Задать вопрос
31 октября, 01:49

Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.

+2
Ответы (1)
  1. 31 октября, 02:25
    0
    Program gt;

    var n, k, t:integer;

    begin

    read (n, k) ;

    t:=0;

    while n>=k do

    begin

    n:=n-k;

    t:=t+1;

    end;

    writeln (t) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) В алгоритме, записанном ниже, используются переменные a и b. Символ ":=" обозначает оператор присваивания, знаки "+", "-", "*" и "/" - соответственно операции сложения, вычитания, умножения и деления.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Заданы два числа 56 (8) и AF (16). Переведите числа в двоичную систему счисления и выполните операции арифметического сложения и умножения, а также операции поразрядного логического сложения и умножения.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
В программе ":=" обозначает оператор присваивания, знаки "+", "-", " * " и " / " соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операции и порядок действий соответствуют правилам арифметики.
Ответы (1)