Задать вопрос
9 апреля, 01:54

Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. Ввод чисел заканчивается нажатием клавиши 0. Протокол работы программы: Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 1 Введите два числа: 15 16 Ответ: 15+16=31 Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 3 Введите два числа: 5 8 Ответ: 5*8=40 Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 0 Пока!

+4
Ответы (1)
  1. 9 апреля, 03:53
    0
    Var a, b, c, x:real;

    begin

    repeat

    writeln ('Введите тип арифм. операции (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - остановить программу') ;

    readln (x) ;

    if x=1 then begin

    writeln ('Введите 2 числа') ;

    readln (a, b) ;

    c:=a+b;

    writeln ('Ответ: ', c) ;

    end;

    if x=2 then begin

    writeln ('Введите 2 числа') ;

    readln (a, b) ;

    c:=a-b;

    writeln ('Ответ: ', c) ;

    end;

    if x=3 then begin

    writeln ('Введите 2 числа') ;

    readln (a, b) ;

    c:=a*b;

    writeln ('Ответ: ', c) ;

    end;

    if x=4 then begin

    writeln ('Введите 2 числа') ;

    readln (a, b) ;

    c:=a/b;

    writeln ('Ответ: ', c) ;

    end;

    if x=0 then writeln ('Пока!') ;

    until x=0;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)
Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице измерения времени и переводит данное число во все остальные единицы измерения
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Напишите все клавиши: 1) Функциональные клавиши - ... 2) Символьные (алфавитно-цифровые) клавиши - ... 3) Клавиши управления курсором - ... 4) Специальные клавиши - ... 5) Дополнительная клавиатура - ... Позязя помогите=В
Ответы (1)
К какой группе онтосится каждая из следущих клавиш? F1, Shift,!1, End, 1End, cтрелочка вниз Символьные клавиши Специальные клавиши Функциональные клавиши Клавиши управления курсором Допольнительные клавиши
Ответы (1)