Задать вопрос
9 мая, 18:53

Дана строка заменить все вхождения "по" на "под". Написать программу на Паскале.

+3
Ответы (1)
  1. 9 мая, 19:34
    0
    Var s:string; i:integer;

    begin

    i:=1;

    read (s) ;

    while i
    begin

    if (s[i]='п') and (s[i+1]='о') then s:=copy (s, 1, i+1) + 'д'+copy (s, i+2, length (s) - i-1) ;

    i:=i+1

    end;

    write (s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка заменить все вхождения "по" на "под". Написать программу на Паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана строка текста, знаков препинания в строке нет. заменить все вхождения "Киров" на "Вятка" На Паскале
Ответы (1)
Написать программу на Python: 1. Использовать для решения задачи count. Дана строка, состоящая из слов, которые разделенны пробелами. Определить, сколько в ней слов. 2. Дана строка. Заменить в этой строке все буквы h на букву H.
Ответы (2)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)