Задать вопрос
8 ноября, 15:47

Дана матрица размера M х N. Вывести ее элементы в следующем

порядке: первая строка слева направо, вторая строка справа налево,

третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks

+2
Ответы (1)
  1. 8 ноября, 19:21
    0
    For (int i = 0; i < m, i++)

    {

    for (int j = 0; j < n; j++)

    {

    if (i % 2 = = 0)

    {

    cout << a[i, j] << " ";

    }

    else

    {

    cout << a[i, n - j - 1] << " ";

    }

    }

    cout << endl;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник? 1 Повтори 3 [Вперёд 50 Направо 20 Направо 25] 2 Повтори 3 [Вперёд 50 Направо 100 Направо 20] 3 Повтори 6 [Вперёд 50 Направо 10 Направо 20] 4 Повтори 6
Ответы (1)
Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Дана целочисленная квадратная матрица M[n][n]. Вывести ее под диагональные элементы, не включая диагональ в виде столбцов слева-направо снизу-вверх
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)