Задать вопрос
19 января, 04:35

Дана целочисленная квадратная матрица M[n][n]. Вывести ее под диагональные элементы, не включая диагональ в виде столбцов слева-направо снизу-вверх

+5
Ответы (1)
  1. 19 января, 04:42
    0
    Программа на паскале, я так понял?

    const n=5;

    var m:array[1 ... n, 1 ... n] of integer; i, j:integer;

    begin

    for i:=1 to n do for j:=1 to n do read (m[i, j]) ;

    for i:=2 to n do begin for j:=1 to i-1 do write (m[i, j],' ') ; writeln; end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана целочисленная квадратная матрица M[n][n]. Вывести ее под диагональные элементы, не включая диагональ в виде столбцов слева-направо ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник? 1 Повтори 3 [Вперёд 50 Направо 20 Направо 25] 2 Повтори 3 [Вперёд 50 Направо 100 Направо 20] 3 Повтори 6 [Вперёд 50 Направо 10 Направо 20] 4 Повтори 6
Ответы (1)
помогите люди)). Дана квадратная целочисленная матрица размера 4 х4. Заменить нулями элементы матрицы, лежащие на главной диагонали. В bordland paskal. задача на двумерный массив
Ответы (1)
Дана целочисленная квадратная матрица, элементы которой вносятся вручную. Написать программу, которая подсчитывает количество четных элементов матрицы, расположенных в первой и последней строке, а также в первом и последнем столбце
Ответы (1)
Дана целочисленная квадратная матрица проверьте являются ли все числа расположенные ниже главной и побожной диагоналей одинаковыми
Ответы (1)