Задать вопрос
21 октября, 22:17

Дана целочисленная квадратная матрица проверьте являются ли все числа расположенные ниже главной и побожной диагоналей одинаковыми

+5
Ответы (1)
  1. 22 октября, 01:51
    0
    Var

    A:array[1 ... 13,1 ... 13] of integer;

    i, j, n, M, k, C:integer;

    Begin

    Randomize;

    N:=Random (13) + 1;

    M:=N div 2 + 2;

    WriteLn ('Исходный массив (', N,') : ') ;

    For i: = 1 to N do

    Begin

    For j: = 1 to N do

    Begin

    A[i, j]:=random (N*2+1) - N;

    Write (A[i, j]:3,' ') ;

    End;

    WriteLn

    End;

    k:=1;

    if (N>2) then

    Begin

    C:=A[M, N-M+2];

    For i: = M to N do

    For j: = N-i+2 to i-1 do

    if A[i, j] C then k:=0;

    if k 0 then WriteLn ('Да')

    else WriteLn ('Нет')

    End

    else WriteLn ('В массиве нет элементов ниже главной и побочной диагоналей.') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана целочисленная квадратная матрица проверьте являются ли все числа расположенные ниже главной и побожной диагоналей одинаковыми ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
помогите люди)). Дана квадратная целочисленная матрица размера 4 х4. Заменить нулями элементы матрицы, лежащие на главной диагонали. В bordland paskal. задача на двумерный массив
Ответы (1)
Pascal. Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его местами с элементом главной диагонали в этой же строке
Ответы (1)
Дана целочисленная квадратная матрица M[n][n]. Вывести ее под диагональные элементы, не включая диагональ в виде столбцов слева-направо снизу-вверх
Ответы (1)
Дана целочисленная квадратная матрица, элементы которой вносятся вручную. Написать программу, которая подсчитывает количество четных элементов матрицы, расположенных в первой и последней строке, а также в первом и последнем столбце
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)