Задать вопрос
6 февраля, 19:10

Написать программу в паскале, которая после введенного с клавиатуры числа (в диапазоне от 1 до 99), обозначающий денежную единицу, дописывал слово "Копейка". Например, 5 копеек, 41 копейка и тд.

Вот мои попытки создать программу:

Program Kopeika;

Var a:integer;

begin

Writeln ('Vvedite chislo') ;

Readln (a) ;

Case a of

'1,21,31,41,51,61,71,81,91': a:='Kopeika ';

'2 ... 4,22 ... 24,32 ... 34,42 ... 44,52 ... 54,62 ... 64,72 ... 74,82 ... 84,92 ... 94': a:='Kopeiki ';

'5 ... 20,25 ... 30,35 ... 40,45 ... 50,55 ... 60,65 ... 70,75 ... 80,85 ... 90,95 ... 99': a:=' Kopeek';

end;

Readln;

end.

+3
Ответы (1)
  1. 6 февраля, 22:44
    0
    Исправленный вариант:

    program Kopeika;

    var

    a: integer;

    begin

    Writeln ('Vvedite chislo') ;

    Readln (a) ;

    case a of

    1, 21, 31, 41, 51, 61, 71, 81, 91: write (a, ' kopeika') ;

    2 ... 4, 22 ... 24, 32 ... 34, 42 ... 44, 52 ... 54, 62 ... 64, 72 ... 74, 82 ... 84, 92 ... 94: write (a, ' kopeiki') ;

    5 ... 20, 25 ... 30, 35 ... 40, 45 ... 50, 55 ... 60, 65 ... 70, 75 ... 80, 85 ... 90, 95 ... 99: write (a, ' kopeek') ;

    end;

    Readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале, которая после введенного с клавиатуры числа (в диапазоне от 1 до 99), обозначающий денежную единицу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике