Задать вопрос
25 октября, 03:43

Написать программу в Паскаль:

1) Составьте программу, которая по заданному году и номеру месяца определит кол-во дней в этом месяце.

2) Для любого 2-ух значного числа, вывести его значение в словесной форме.

+2
Ответы (1)
  1. 25 октября, 07:12
    0
    1)

    var y, m, d:integer;

    begin

    read (y, m) ;

    case m of

    1,3,5,7,8,10,12: d:=31;

    4,6,9,11: d:=30;

    2:if (y mod 40) then d:=28 else

    if (y mod 1000) then d:=29 else

    if (y mod 4000) then d:=28 else

    d:=29;

    end;

    writeln (d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскаль: 1) Составьте программу, которая по заданному году и номеру месяца определит кол-во дней в этом месяце. 2) Для ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить прогрмму в паскале-кейс. которая по заданному году и номеру месяца m определяет оличество дней в этом месяце
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Написать программу которая вводит номер месяца и определяет по этому номеру время года, и название выводит на экран и если число больше 12, то такого номера месяца не существует, язык паскаль
Ответы (1)