Задать вопрос
27 декабря, 23:09

Составить программу в Паскаль: Даны 4 числа, выделить целые части и найти среднее арифметическое этих чисел.

+5
Ответы (1)
  1. 27 декабря, 23:57
    0
    Var

    i:integer;

    a, c:real;

    begin

    c:=0;

    Writeln ('Введите четыре произвольных числа') ;

    for i:=1 to 4 do

    begin

    Read (a) ; c:=c+Int (a)

    end;

    c:=c/4;

    Writeln ('Среднее арифметическое равно ', c)

    end.

    Тестовое решение:

    Введите четыре произвольных числа

    4.7 5.03 4.12 5

    Среднее арифметическое равно 4.5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Паскаль: Даны 4 числа, выделить целые части и найти среднее арифметическое этих чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)