Задать вопрос
8 февраля, 04:37

Составить прогрмму в паскале-кейс.

которая по заданному году и номеру месяца m определяет оличество дней в этом месяце

+4
Ответы (1)
  1. 8 февраля, 05:23
    0
    Var

    n, y: integer;

    begin

    write ('Введите месяц (1-12) и год (2001-2099) : ') ;

    readln (n, y) ;

    case n of

    1, 3, 5, 7, 8, 10, 12: writeln ('31 день') ;

    4, 6, 9, 11: writeln ('30 дней') ;

    2: if y mod 4 = 0 then write ('29 дней') else write ('28 дней')

    end

    end.

    Тестовое решение:

    Введите месяц (1-12) и год (2001-2099) : 7 2014

    31 день
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить прогрмму в паскале-кейс. которая по заданному году и номеру месяца m определяет оличество дней в этом месяце ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в Паскаль: 1) Составьте программу, которая по заданному году и номеру месяца определит кол-во дней в этом месяце. 2) Для любого 2-ух значного числа, вывести его значение в словесной форме.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. При вводе неверного месяца должно быть выведено сообщение об ошибке.
Ответы (1)
Составить программу в Pascal ABC, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)
Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)