Задать вопрос
9 июля, 18:20

Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. При вводе неверного месяца должно быть выведено сообщение об ошибке.

+4
Ответы (1)
  1. 9 июля, 18:39
    0
    Var a, b, c, d, e:real;

    begin

    b : = 30;

    c : = 31;

    d : = 29;

    e : = 28;

    writeln ('От 1 до 12') ;

    readln (a) ;

    if a = 1 then writeln (c) ;

    if a = 2 then writeln (d,' или ', e) ;

    if a = 3 then writeln (c) ;

    if a = 4 then writeln (b) ;

    if a = 5 then writeln (c) ;

    if a = 6 then writeln (b) ;

    if a = 7 then writeln (c) ;

    if a = 8 then writeln (c) ;

    if a = 9 then writeln (b) ;

    if a = 10 then writeln (c) ;

    if a = 11 then writeln (b) ;

    if a = 12 then writeln (c) ;

    else writeln ('Неправильно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. При вводе неверного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Составить программу в Pascal ABC, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)
Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)