Задать вопрос
29 мая, 12:39

Составить программу, которая упорядочивает 2 числа по убыванию и находит максимальное из них.

+4
Ответы (2)
  1. 29 мая, 12:56
    0
    Uses crt;

    var x, y, max: real;

    begin

    read (x, y) ;

    writeln;

    if x>y then begin

    write (x,' ', y) ;

    max:=x;

    end

    else begin

    max:=y;

    write (y,' ', x)

    end;

    writeln;

    writeln ('Максимум: ', max) ;

    end.
  2. 29 мая, 15:51
    0
    Var a, b:integer;

    begin

    writeln (a) ;

    readln (a) ;

    writeln (b) ;

    readln (b) ;

    if a>b then writeln (a, ', ', b) else writeln (b, ', ', a) ;

    if a>b then writeln (a, ' - максимум') else writeln (b, ' - максимум') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая упорядочивает 2 числа по убыванию и находит максимальное из них. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая упорядочивает элементы четных строк по возрастанию, а нечетных по убыванию. Матрица размером 8 х8. Полученную матрицу напечатать.
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
На языке программирования Паскаль напишите программу, которая: 1) В последовательности чисел находит количество чисел, кратных 3. 2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)