Задать вопрос
31 января, 23:08

Составить программу, которая упорядочивает элементы четных строк по возрастанию, а нечетных по убыванию. Матрица размером 8 х8. Полученную матрицу напечатать.

+1
Ответы (1)
  1. 1 февраля, 00:31
    0
    Var

    i, j, k, p:integer;

    a:array[1 ... 8,1 ... 8]of integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 8 do

    begin

    for j:=1 to 8 do

    begin

    a[i, j]:=random (20) ;

    write (a[i, j]:3)

    end;

    writeln

    end;

    for i: = 1 to 8 do

    for j: = 1 to 8 do

    for k: = 1 to 8 do

    begin

    if i mod 2=0 then

    begin

    if (a[i, j]
    begin

    p:=a[i, j];

    a[i, j] : = a[i, k];

    a[i, k] : = p

    end

    end

    else

    if a[i, j] > a[i, k] then

    begin

    p:=a[i, j];

    a[i, j] : = a[i, k];

    a[i, k] : = p

    end

    end;

    writeln ('Преобразованный массив:') ;

    for i:=1 to 8 do

    begin

    for j:=1 to 8 do

    write (a[i, j]:3) ;

    writeln

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая упорядочивает элементы четных строк по возрастанию, а нечетных по убыванию. Матрица размером 8 х8. Полученную ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Отсортировать элементы четных строк матрицы по возрастанию значения, а нечетных - по убыванию значения -
Ответы (1)
Ввести матрицу А размерностью 3*n. B (n*3). Найти матрицу С (3*n) = A (3*n) B (3*n). Найтм сумму чисел, находящихся в четных строках, нечетных столбцах. Составить блок схему и программу
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)