Задать вопрос
6 декабря, 20:21

Отсортировать элементы четных строк матрицы по возрастанию значения, а нечетных - по убыванию значения -

+5
Ответы (1)
  1. 6 декабря, 21:56
    0
    Const

    N = 6;

    M = 7;

    Var

    A:array[1 ... N, 1 ... M] of integer;

    i, j, k, MM, B:integer;

    Begin

    Randomize;

    WriteLn ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    For j: = 1 to M do

    Begin

    A[i, j]:=random (21) - 10;

    Write (A[i, j]:3,' ')

    End;

    WriteLn

    End;

    WriteLn;

    WriteLn ('Отсортированный массив:') ;

    For i: = 1 to N do

    Begin

    For j: = 1 to M do

    Begin

    MM:=j;

    if i mod 2 = 0 then

    Begin

    For k: = j+1 to M do

    if A[i, MM] > A[i, k] then MM:=k

    End

    else

    For k: = j+1 to M do

    if A[i, MM] < A[i, k] then MM:=k;

    B:=A[i, MM];

    A[i, MM]:=A[i, j];

    A[i, j]:=B;

    Write (A[i, j]:3,' ')

    End;

    WriteLn

    End

    End.

    Пример работы программы:

    Исходный массив:

    9 - 5 6 0 - 9 0 9

    3 - 9 - 4 10 - 8 10 3

    -2 1 2 3 3 0 10

    -10 1 8 - 3 - 4 - 3 4

    -9 - 7 - 3 - 9 2 - 1 - 3

    7 - 10 10 - 3 4 10 0

    Отсортированный массив:

    9 9 6 0 0 - 5 - 9

    -9 - 8 - 4 3 3 10 10

    10 3 3 2 1 0 - 2

    -10 - 4 - 3 - 3 1 4 8

    2 - 1 - 3 - 3 - 7 - 9 - 9

    -10 - 3 0 4 7 10 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Отсортировать элементы четных строк матрицы по возрастанию значения, а нечетных - по убыванию значения - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Составить программу, которая упорядочивает элементы четных строк по возрастанию, а нечетных по убыванию. Матрица размером 8 х8. Полученную матрицу напечатать.
Ответы (1)
1. Имеется одномерный массив размерностью 20, заполненный рандомными числами на отрезке от 1 до 20. Требуется удалить из него максимальный и минимальный элементы Примечание: Алгоритм удаления: сдвигаются все элементы на 1 позицию влево, начиная с
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)