Задать вопрос
2 января, 00:28

Задача на паскале.

Заданы 2 числа. Определить, какое из них встречается в массиве чаще.

(нужно полное решение)

+1
Ответы (1)
  1. 2 января, 04:03
    0
    const max=10;

    var

    mas:array[1 ... max] of integer;

    a, b:integer;

    countA, countB:integer;

    i:integer;

    begin

    readln (a, b) ;

    for i:=1 to max do

    begin

    readln (mas[i]) ;

    if (mas[i]=a) then countA:=countA+1;

    if (mas[i]=b) then countB:=countB+1;

    end;

    if (countA>countB) then writeln ('Число', a,' встречается больше') ;

    if (countB>countA) then writeln ('Число', b, ' встречается больше') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача на паскале. Заданы 2 числа. Определить, какое из них встречается в массиве чаще. (нужно полное решение) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, находящихся в массиве до последнего нуля. Если нулей в массиве нет, то рассортировать все числа по убыванию.
Ответы (1)
Задача решается в паскале. В одномерном массиве найти сумму всех элеметнов кроме мах и тип найти: 1) сумма элемента массива. 2) мах в массиве.
Ответы (1)
Программа на паскале В массив записаны случайные числа от 1 до 10, количество элементов в массиве 10000. Определить какое число чаще всего повторяется
Ответы (2)
Дано: массивы А (8), В (11). Определить в каком массиве отрицательное число встречается раньше. Номер первого отрицательного элемента в массиве находить в подпрограмме.
Ответы (1)
Решите в паскале. Составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8, r8, r9, r10, r11, r12, r13, r14, r15, r16, r17, r18, r19, r20 соединение паралельное. Сопротивления заданы в массиве, напряжение вводится.
Ответы (1)