Задать вопрос
18 сентября, 20:00

2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, находящихся в массиве до последнего нуля. Если нулей в массиве нет, то рассортировать все числа по убыванию.

+1
Ответы (1)
  1. 18 сентября, 22:18
    0
    Const nx = 50;

    var z:array[1 ... nx] of integer; i, j, n, m, d, s, s1, k:integer; sr:real;

    begin

    write ('Введите число элементов n') ; read (n) ;

    for i: = 1 to n do begin

    z[i]: = random (30) - 5;

    write (z[i]:3) ;

    if z[i]=0 then m:=i; end; writeln;

    if m > 0 then begin

    for j:=1 to n do begin

    if (j< m) and (z[j] mod 2 = 0) then s: = s + z[j];

    if (j> m) and (z[j] mod 2 = 1) then begin s1: = s1 + z[j]; k: = k + 1; end; end; end

    else

    begin

    writeln;

    for i:=1 to n do begin

    for j:=2 to n do begin

    if z[j] > z[j-1] then begind:=z[j-1]; z[j-1]:=z[j]; z[j]: = d; end; end;

    end; end; writeln;

    sr: = s1 / k;

    if m > 0 then begin

    writeln ('сумму нечетных чисел от последнего нулевого значения до Z[N]', s:6) ;

    write ('среднее арифметическое четных чисел, находящихся в массиве до последнего нуля ', sr:6:3) ;

    end

    else

    for j:=1 to n do

    write (z[j]:3) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)