Задать вопрос
25 апреля, 05:26

Программа на паскале

В массив записаны случайные числа от 1 до 10, количество элементов в массиве 10000. Определить какое число чаще всего повторяется

+3
Ответы (2)
  1. 25 апреля, 07:16
    0
    Не самый лёгкий, но работающий способ

    const n = 10000; //Не изменяемая по ходу программы переменная

    var a: array[1 ... n] of integer; b: array[1 ... 10]of integer; c: array[1 ... 10]of integer; i, s, v: integer;

    begin for i : = 1 to 10 do / / Заполнение массива с числами от 1 до 10 c[i] : = i; for i : = 1 to n do / / Заполнение массива a[i] : = random (10) + 1; / / Делается для того чтобы в массиве не было нулей for i : = 1 to n do case a[i] of 1: b[1] : = b[1] + 1; 2: b[2] : = b[2] + 1; 3: b[3] : = b[3] + 1; 4: b[4] : = b[4] + 1; 5: b[5] : = b[5] + 1; 6: b[6] : = b[6] + 1; 7: b[7] : = b[7] + 1; 8: b[8] : = b[8] + 1; 9: b[9] : = b[9] + 1; 10: b[10] : = b[10] + 1; End; for i : = 1 to 10 do for s : = 1 to 9 do if b[s] > b[s + 1] then begin v : = b[s]; b[s] : = b[s + 1]; b[s + 1] : = v; v : = c[s]; c[s] : = c[s + 1]; c[s + 1] : = v; end; writeln (c[10], ' - их ', b[10]) ; end.
  2. 25 апреля, 08:34
    0
    Для этого задания необязательно делать массив из 10000 элементов, но если надо то вот простейший вариант.

    var

    a:array[1 ... 10000] of byte;

    count:array[1 ... 10] of integer;

    i, max, index:integer;

    begin

    for i:=1 to 10000 do

    begin

    a[i]:=random (10) + 1;

    inc (count[ a[i] ]) ;

    end;

    for i:=1 to 10 do

    if max < count[i] then

    begin

    max: = count[i];

    index: = i;

    end;

    writeln (index,' Повторяется ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа на паскале В массив записаны случайные числа от 1 до 10, количество элементов в массиве 10000. Определить какое число чаще всего ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Умышленные угрозы подразделяются на: 1) случайные и пассивные 2) случайные, пассивные и активные 3) случайные и активные 4) пассивные и активные 5) случайные и непреднамеренные
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)