Задать вопрос
30 января, 08:50

Даны две последовательности а1, а2, ... аn и b1, b2 ... bm. (m
Решить в Паскале, с помощью одномерных массивов

+5
Ответы (1)
  1. 30 января, 11:44
    0
    Const n = 100;

    const m = 50;

    var a:array[1 ... n] of integer;

    b:array[1 ... n] of integer;

    i, it, bo:integer;

    begin

    for i: = 1 to n do

    a[i] : = trunc (Random (100)) ;

    for i: = 1 to m do

    b[i] : = trunc (Random (100)) ;

    bo:=1;

    for i:=1 to m do

    if bo = 1 then

    for it:=1 to n do

    if b[i] a[it] then begin bo: = 0; break; end;

    if bo = 1 then write ('Входят') else write ('Не входят') ;

    end.

    если я правильно понял задание то так
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны две последовательности а1, а2, ... аn и b1, b2 ... bm. (m ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Даны две последовательности символов (любых). Определить количество букв в первой последовательности, повторяющихся во второй последовательности. Паскаль
Ответы (1)
Даны последовательности А, В, С. В каждой из них 20 целых чисел. В той последовательности, где больше всего 0 (считая что такая последовательность одна), все 0 заменить наибольшим значением данной последовательности (теория алгоритмов)
Ответы (1)
Pascal Даны 3 числовые последовательности a, b, c. Сформировать две новые последовательности x, y в соответсвии с правилом xi=min (ai, bi) / 2 yi=min (bi, ci) / 2 i=1,2 ... n
Ответы (1)
Артём записывает на доске последовательности чисел. На первом шаге он написал число 3. Затем стер его и записал 1 3 (что означает "одна тройка", то есть, записал описание стертой последовательности).
Ответы (1)