Задать вопрос
4 января, 08:40

Решите в паскале. Составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8, r8, r9, r10, r11, r12, r13, r14, r15, r16, r17, r18, r19, r20 соединение паралельное. Сопротивления заданы в массиве, напряжение вводится.

+1
Ответы (1)
  1. 4 января, 09:41
    0
    Uses crt;

    const R: array[1 ... 20] of integer = (1, 2, 3, 4, 5, 6, 7, 8, 9, 10,

    11, 12, 13, 14, 15, 16, 17, 18, 19, 20) ;

    var I:array [1 ... 20] of real;

    U, x:integer;

    SUM:real;

    begin

    write ('U=') ; readln (U) ;

    for x:=1 to 20 do

    begin

    write ('R[', x,']:', R[x],' ') ;

    I[x]:=U/R[x];

    SUM:=SUM+I[x];

    writeln ('I[', x,']:', I[x]:5:3) ;

    end;

    writeln ('I=', SUM:5:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите в паскале. Составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8, r8, r9, r10, r11, r12, r13, r14, r15, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
1. Файл размером 4 Мбайт передаётся через некоторое соединение за 100 секунд. Определите размер файла (в Кбайтах), который можно передать через это же соединение за 75 секунд. 2.
Ответы (1)