Задать вопрос
3 октября, 19:14

На языке программирования Паскаль напишите программу, которая:

1) В последовательности чисел находит количество чисел, кратных 3.

2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.

+3
Ответы (1)
  1. 3 октября, 20:04
    0
    1)

    program kr3sum;

    var i, s. h:integer;

    begin

    read (k) / / кол чисел

    for i:=1 to k do begin

    read (h) / / число для действий

    if h mod 3 = 0 then begin s:=s+1;

    end;

    writeln (s) ;

    end.

    2)

    program jeje;

    var k, i, m, s, h:integer;

    begin m:=0;

    read (k) ; / / кол-во чисел

    for i:=1 to k do begin

    readln (h) ;

    if h mod 10 = 4 then begin s:=h;

    if s > m then m:=s

    end;

    end;

    write (m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На языке программирования Паскаль напишите программу, которая: 1) В последовательности чисел находит количество чисел, кратных 3. 2) В ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Напишите программу на Паскаль, которая в последовательности натуральных чисел определяет максимальное отрицательное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)