Задать вопрос
18 ноября, 12:35

Напишите программу на Паскаль, которая в последовательности натуральных чисел определяет максимальное отрицательное число, оканчивающееся на 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000. Введенные числа по абсолютной величине не превышают 30 000.

Программа должна вывести одно число-максимальное отрицательное число, оканчивающееся на 3.

+5
Ответы (1)
  1. 18 ноября, 15:46
    0
    Var n, a, max, i:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    max:=-30000;

    writeln ('Вводите числа:') ;

    for i:=1 to n do

    begin

    readln (a) ;

    if (abs (a) mod 10=3) and (amax) then max:=a;

    end;

    if max=-30000 then writeln ('Нет чисел, оканчивающихся на 3')

    else writeln ('max = ', max) ;

    end.

    Пример:

    n = 5

    Вводите числа:

    5

    618

    -703

    103

    -243

    -815max = - 243
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на Паскаль, которая в последовательности натуральных чисел определяет максимальное отрицательное число, оканчивающееся ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)