Задать вопрос
7 февраля, 09:21

Паскаль!

Даны координаты левой верхней и правой нижней вершин квадрата. Найти координаты точки пересечения диагоналей квадрата.

+4
Ответы (2)
  1. 7 февраля, 11:33
    0
    Var

    x1, x2, y1, y2:real;

    Begin

    Write ('x1 = ') ;

    ReadLn (x1) ;

    Write ('y1 = ') ;

    ReadLn (y1) ;

    Write ('x2 = ') ;

    ReadLn (x2) ;

    Write ('y2 = ') ;

    ReadLn (y2) ;

    WriteLn (' (', x1 + (x2-x1) / 2,',', y2 + (y1-y2) / 2,') ')

    End.
  2. 7 февраля, 12:46
    0
    Var x1, y1, x2, y2, x, y:real;

    begin

    writeln ('Введите координаты левой верхней вершины квадрата') ;

    readln (x1, y1) ;

    writeln ('Введите координаты правой нижней вершины квадрата') ;

    readln (x2, y2) ;

    x:=x1 + (x2-x1) / 2;

    y:=y2 + (y1-y2) / 2;

    writeln ('Координаты точки пересечения диагоналей квадрата:') ;

    writeln ('x = ', x,' y = ', y) ;

    end.

    Пример:

    Введите координаты левой верхней вершины квадрата

    4 3

    Введите координаты правой нижней вершины квадрата

    6 1

    Координаты точки пересечения диагоналей квадрата:

    x = 5 y = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! Даны координаты левой верхней и правой нижней вершин квадрата. Найти координаты точки пересечения диагоналей квадрата. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать задачу на языке PascalABC 3.1 На улице дома с чётными номерами находятся с левой стороны, а с нечётными - с правой. Известно количество жителей в каждом доме. Посчитайте разницу между суммарными количествами жителей левой стороны и правой.
Ответы (1)
На столе стоят три вазы с конфетами. В левой вазе лежат A конфет, в средней вообще лежат B конфет, в правой вазе лежат C конфет.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
укажите, как выделить следующий фрагмент (соеденить стрелками). Отдельное слово 1) Подвести указатель мыши к левой границе строки так, чтобы он принял виднаклонной стрелки. 2) выполнить щелчок левой кнопкой мыши.
Ответы (1)
Составьте программу в Паскале. Условный оператор. Ввести число А. Начертить вертикальную линию в левой части экрана если A
Ответы (1)