Задать вопрос
20 сентября, 01:32

Написать задачу на языке PascalABC 3.1

На улице дома с чётными номерами находятся с левой стороны, а с нечётными - с правой. Известно количество жителей в каждом доме. Посчитайте разницу между суммарными количествами жителей левой стороны и правой.

Входные данные

Первая строка состоит из одного числа

n (1⩽n⩽1000) - количество домов на улице. Следующая строка содержит n целых чисел xi (0⩽xi⩽10000) - количество жителей в i-м доме (1⩽i⩽n).

Результат

Нужно вывести одно целое число - разницу между суммарными количествами жителей левой стороны улицы и правой.

Пример

Исходные данные

3

3 1 4

Результат

-6

Пояснение: на левой стороне 1 житель, на правой 7, разница равна 1

+2
Ответы (1)
  1. 20 сентября, 04:18
    0
    Program t;

    varn, x, i, s, k:integer;

    a:array [0 ... 20] of integer; {20 = это максимальное количество домов. Вместо 20 поставь любое число}

    begin

    write ('Введите количество домов на улице : ') ;

    read (n) ;

    for i:=1 to n do

    begin

    write ('Введите количество жителей в ', i, ' - м доме : ') ;

    read (a[i]) ;

    end;

    for i:=1 to n do

    if i mod 2=0 then s:=a[i]+s; {Считаем жителей правых}

    for i:=1 to n do

    if i mod 2=1 then k:=a[i]+k; {Считаем жителей левых}

    if s>k then write ('Разница между домами ', k-s) ;

    if s
    end.

    Введите количество домов на улице: 3

    Введите количество жителей в 1 - м доме: 3

    Введите количество жителей в 2 - м доме: 1

    Введите количество жителей в 3 - м доме: 4

    Разница между домами - 6

    Писал на Версии 3.3

    Скобки это комментарии, их можно убрать
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать задачу на языке PascalABC 3.1 На улице дома с чётными номерами находятся с левой стороны, а с нечётными - с правой. Известно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать задачу на языке PascalABC По одну сторону улицы находятся дома с нечетными номерами (1,3,5, ...), по другую сторону - четными (2,4,6, ...). Дом 1 находится напротив дома 2, дом 3 - напротив дома 4 и тд.
Ответы (1)
Известно число жителей, проживающих в каждом доме улицы. Нумерация домов проведена подряд. Дома с нечетными номерами расположены на одной стороне улицы, с четными - на другой. На какой стороне улицы проживает больше жителей? (в паскале АВС)
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Задача 1. Улица По одну сторону улицы находятся дома с нечётными номерами (1, 3, 5, ...), по другую сторону - с чётными (2, 4, 6, ...). Дом № 1 находится напротив дома № 2, дом № 3 - напротив дома № 4 и т. д.
Ответы (2)
Помогите решить! Задача 1. По одну сторону улицы находятся дома с нечетными номерами (1,2,5, ...) По другую сторону - с четными (2,4,6, ...). Дом 1 находится напротив дом 2, дом 3 - напротив дома 4 и тд.
Ответы (2)