Задать вопрос
6 августа, 23:57

Помогите решить!

Задача 1.

По одну сторону улицы находятся дома с нечетными номерами (1,2,5, ...)

По другую сторону - с четными (2,4,6, ...). Дом 1 находится напротив дом 2, дом 3 - напротив дома 4 и тд. До соседнего дома нужно идти вдоль по улице одну минуту, неважно, с какой стороны улицы он находится (то есть от дома 1 нужно идти одну минуту как до дома 3 так и до дома 4) до дома стоящего напротив, идти не нужно.

Человек вышел на улицу из дома номер А и должен дойти до дома номер В. Определите сколько минут ему нужно идти вдоль по улице.

Программа получает на вход два различных целых положительных числа А и В не превосходящии 2*10^9 - номера домов. Программа должна вывести одно число - искомое количество минут.

+5
Ответы (2)
  1. 7 августа, 01:34
    0
    вот решение на паскале (P. S. сам додумался)

    begin

    var a:=ReadInteger;

    var b:=ReadInteger;

    var min:=0.0;

    for var i:=a to b do

    begin

    min+=0.5;

    end;

    If odd (a) and not odd (b) then

    write (min-1) ;

    If not odd (a) and odd (b) then

    write (min) ;

    If (not odd (a) and not odd (b)) or (odd (a) and odd (b)) then

    write (min-0.5) ;

    end.
  2. 7 августа, 03:45
    0
    П0 П1 1 - П1 2 / [x] ИП0 1 - 2 / [x] ИП1 - |x| С/П

    Пример: расстояние от дома 1 до дома 5 равно 2.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить! Задача 1. По одну сторону улицы находятся дома с нечетными номерами (1,2,5, ...) По другую сторону - с четными (2,4,6, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1. Улица По одну сторону улицы находятся дома с нечётными номерами (1, 3, 5, ...), по другую сторону - с чётными (2, 4, 6, ...). Дом № 1 находится напротив дома № 2, дом № 3 - напротив дома № 4 и т. д.
Ответы (2)
Написать задачу на языке PascalABC По одну сторону улицы находятся дома с нечетными номерами (1,3,5, ...), по другую сторону - четными (2,4,6, ...). Дом 1 находится напротив дома 2, дом 3 - напротив дома 4 и тд.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Написать задачу на языке PascalABC 3.1 На улице дома с чётными номерами находятся с левой стороны, а с нечётными - с правой. Известно количество жителей в каждом доме. Посчитайте разницу между суммарными количествами жителей левой стороны и правой.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)