Задать вопрос
16 июня, 11:32

На столе стоят три вазы с конфетами. В левой вазе лежат A конфет, в средней вообще лежат B конфет, в правой вазе лежат C конфет. Лена съедает одну конфету из левой вазы, затем-одну конфету из средней вазы, затем из правой, средней вазы, затем из правой, средней, левой, средней, правой, средней и т. д.

Если Лена хочет взять конфету из какой-то вазы, а конфет там нет, она расстраивается и идёт спать. Определите, сколько конфет съест Лена

Программа получает на вход три целых неотрицательных числа A, B, C-количество конфет в левой, средней, правой ВАЗе.

+2
Ответы (1)
  1. 16 июня, 13:00
    0
    Var a, b, c, n:integer; f:boolean;

    begin

    readln (a, b, c) ;

    f:=true; n:=0;

    while f do

    begin

    if f and (a>0)

    then begin a:=a-1; n:=n+1; end else f:=false;

    if f and (b>0)

    then begin b:=b-1; n:=n+1; end else f:=false;

    if f and (c>0)

    then begin c:=c-1; n:=n+1; end else f:=false;

    if f and (b>0)

    then begin b:=b-1; n:=n+1; end else f:=false;

    end;

    writeln (n) ;

    end.

    Пример:

    3 3 3

    7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На столе стоят три вазы с конфетами. В левой вазе лежат A конфет, в средней вообще лежат B конфет, в правой вазе лежат C конфет. Лена ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Написать задачу на языке PascalABC 3.1 На улице дома с чётными номерами находятся с левой стороны, а с нечётными - с правой. Известно количество жителей в каждом доме. Посчитайте разницу между суммарными количествами жителей левой стороны и правой.
Ответы (1)
Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.
Ответы (1)
составьте программу которая получает на вход с клавиатуры три неотрицательных целых числа a, b, c, (каждое число с новой строки) и выводит на экран число 1. Если сумма двух каких либо введеных чисел меньше 100.
Ответы (1)
Напишите программу, которая для последовательности целых чисел определяет количество четных чисел. Программа получает на вход количество чисел в последоввтельности, а затем сами числа. Количество чисел не привышает 1000.
Ответы (1)