Задать вопрос
2 июня, 06:02

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания

+1
Ответы (1)
  1. 2 июня, 09:41
    0
    Uses crt;

    const n=8;

    var a:integer;

    b:array[1 ... n] of integer;

    i, k, t:integer;

    begin

    readln (a) ;

    k:=1;

    repeat

    for i:=k to k do

    b[i]:=a mod 10;

    a:=a div 10;

    inc (k) ;

    until a=0;

    t:=0;

    for i:=k-1 downto 2 do

    if (b[i]>b[i-1]) then inc (t) ;

    if t=0 then writeln ('yes') else writeln ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы в Pascal: 1. Ввести целое число и определить, верно ли, что все его цифры расположены в порядке возрастания ... 2. Ввести целое число и "перевернуть" его, так чтобы первая цифра стала последней и т. д.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Задание: Написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания.
Ответы (1)
Задача Pascal, цикл While Ввести целое число и определить, верно ли, что все его цифры чётные Пример: Введите число: 2684:да
Ответы (1)