Задать вопрос
2 февраля, 06:32

Задание:

Написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания.

Написать программу, получающую с клавиатуры целое число и выводящую его наоборот

(Например: вводим: 123, а выводит: 321).

+4
Ответы (1)
  1. 2 февраля, 08:49
    0
    Var

    A:longint;

    B:boolean;

    Begin

    B:=true;

    Write ('Введите целое число: ') ; ReadLn (A) ;

    A:=Abs (A) ;

    While A div 10 > 0 do

    Begin

    if A mod 10 < A div 10 mod 10 then B:=false;

    A:=A div 10

    End;

    if B then Write ('Верно')

    else Write ('Не верно')

    End.

    Var

    A:longint;

    Begin

    Write ('Введите целое число: ') ; ReadLn (A) ;

    if A < 0 then

    Begin

    Write ('-') ;

    A:=-A;

    End;

    While A > 0 do

    Begin

    Write (A mod 10) ;

    A:=A div 10

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание: Написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Из данного натурального числа n, удалить все цифры 5 (n вводиться с клавиатуры). Например вводим 25455, выводит 24.
Ответы (1)
Составьте программу, определяющую, является ли введенное с клавиатуры целое число кратным 3. Пример ввода: 123 Пример вывода: Число 123 кратно 3
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
1. Написать программу, которая после ввода числа выводит все числа от нуля по это число: например, вводим 3 - выводим 0, 1, 2, 3. (Puthon)
Ответы (1)