Задать вопрос
24 мая, 12:26

Из данного натурального числа n, удалить все цифры 5 (n вводиться с клавиатуры). Например вводим 25455, выводит 24.

+3
Ответы (1)
  1. 24 мая, 14:03
    0
    var s:string;

    i:byte;

    begin

    read (s) ;

    if (length (s) = 1) and (s='5') then writeln (' ') else begin

    while ilength (s) do

    begin

    i:=i+1;

    if copy (s, i, 1) = '5' then begin delete (s, i, 1) ; i:=i-1; end;

    end;

    writeln (s) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Из данного натурального числа n, удалить все цифры 5 (n вводиться с клавиатуры). Например вводим 25455, выводит 24. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
1. Написать программу, которая после ввода числа выводит все числа от нуля по это число: например, вводим 3 - выводим 0, 1, 2, 3. (Puthon)
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Составить программу вычисления суммы цифр 5-значного числа вводимого с клавиатуры где N вводиться с клавиатуры
Ответы (1)
Составьте задачу на Паскаль, используя диалог с пользователем. Компьютер выводит на экран: -Здравствуй, я компьютер, а тебя как зовут? Человек вводит с клавиатуры: -Коля Компьютер выводит на экран: -Очень приятно, Коля.
Ответы (1)