Задать вопрос
22 мая, 20:13

Задача Pascal, цикл While

Ввести целое число и определить, верно ли, что все его цифры чётные

Пример:

Введите число: 2684:да

+5
Ответы (1)
  1. 22 мая, 20:58
    0
    Var A:longint;

    k:integer;

    Begin

    Write ('Введите целое число: ') ; ReadLn (A) ;

    k:=0;

    While A0 do

    Begin

    if (A mod 10) mod 2 0 then k:=1;

    A:=A div 10

    End;

    if k=0 then WriteLn ('Да')

    else WriteLn ('Нет')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача Pascal, цикл While Ввести целое число и определить, верно ли, что все его цифры чётные Пример: Введите число: 2684:да ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Задача Pascal, цикл While Ввести целое число и определить, верно ли, что в нем ровно 3 цифры. Пример: Введите число: 123:да
Ответы (1)
Ввести целое число и определить, верно ли, что в нём ровно 3 цифры. Нужно с помощью цикла "while" Пример: Введите число: 123 Да Пример: Введите число: 1234 Нет.
Ответы (1)
Напишите программы в Pascal: 1. Ввести целое число и определить, верно ли, что все его цифры расположены в порядке возрастания ... 2. Ввести целое число и "перевернуть" его, так чтобы первая цифра стала последней и т. д.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)