Задать вопрос
22 мая, 13:42

Дан массив из 10 целых элементов из диапазона [-10; 7]. переписать в другой массив все нечетные элементы. при этом вывести исходный и полученный массив

+2
Ответы (1)
  1. 22 мая, 17:09
    0
    Var a, b: array [1 ... 10] of integer;

    i, j: integer;

    begin

    j : = 1;

    for i : = 1 to 10 do

    read (a[i]) ;

    for i : = 1 to 10 do

    if (a[i] mod 2) 0 then

    begin

    b[j] : = a[i];

    inc (j) ;

    end;

    for i : = 1 to 10 do

    write (a[i], ' ') ;

    writeln;

    for i : = 1 to j - 1 do

    write (b[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 целых элементов из диапазона [-10; 7]. переписать в другой массив все нечетные элементы. при этом вывести исходный и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Задача 1. Дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от - 15 до + 50. Вычислить сумму всех элементов массива, определить количество элементов массива кратных 3.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)