Задать вопрос
30 ноября, 13:19

Решите в паскале ABC.

Известно время полета вылета самолета - HH часов и ММ

минут, а также продолжительность полета (НР часов и МР минут). Напечатать время

прибытия самолета в аэропорт назначения в виде: самолет прибывает в

12.35. Учесть возможность перехода часов (после 23.59 наступает 00.00).

+2
Ответы (1)
  1. 30 ноября, 14:51
    0
    Program time;

    uses crt;

    var

    HH, MM, HP, MP, HR, MR, ost:integer;

    begin

    write ('Vvedite vremya otvravki : ') ;

    read (HH) ;

    read (MM) ;

    writeln;

    write ('vvedite prodolgitelnost poleta: ') ;

    read (hp) ;

    read (mp) ;

    clrscr;

    writeln ('Otpravleniye somolyata v ', hh,':', mm) ;

    MR:=mm+mp;

    if mr>59 then

    begin

    ost:=mr mod 60;

    MR:=ost;

    HR:=HR + (MR div 60) ;

    end;

    HR:=HH+HP;

    if hr>24 then hr:=hr - 24;

    Writeln;

    Write ('Pributie samolyota v ', HR,':', MR) ;

    writeln;

    end.

    данный можно сразу вводить через пробел ...

    например 12 10 жмем ентер и вводим другие 14 55 и ентер и все прекрасно посчитает. тут опечатка ... не совсем правильно считает ... подожди исправлю
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите в паскале ABC. Известно время полета вылета самолета - HH часов и ММ минут, а также продолжительность полета (НР часов и МР минут). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут).
Ответы (1)
Известно время вылета самолета: HH часов и ММ минут, а также продолжительность полета (НМ часов и МР минут). Напишите программу, которая определяет время прибытия самолета в аэропорт назначение ввиде "чч: мм"
Ответы (1)
Задача Полет Известно время вылета самолёта НН часов и ММ минут, а также продолжительность полёта (НР часов и МР минут) Напишите программу, которая определяет время прибытия самолёта в аэропорт Назначение в формате "чс: мм"
Ответы (1)
Определи, для кого сообщение о задержке вылета самолета является актуальной информацией? 1) Туриста, прилетевшего в аэропорт. 2) Туриста, купившего билет на самолет. 3) Животных, отправляющихся вместе с хозяевами в полет.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)