Задать вопрос
3 августа, 05:48

Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая определяет время прибытия самолета в аэропорт назначения в виде "чч: мм" Формат входных данных: С клавиатуры вводится четыре числа через пробел НН, ММ, НР, МР, обозначающие соответственно часы и минуты вылета и часы и минуты продолжительности полета. Формат выходных данных: На экран вывести время прибытия самолета в аэропорт назначения в виде "чч: мм

+3
Ответы (1)
  1. 3 августа, 06:22
    0
    Var

    hh, mm, hp, mp: integer;

    begin

    readln (hh, mm, hp, mp) ;

    hh : = hp * 60 + hh * 60 + mm + mp;

    writeln (hh div 60 mod 24, ':', hh mod 60) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Из-за непогоды были отменены рейсы самолетов. Ненадолго проглянуло солнце: на N часов и M минут. Напишите программу, которая определяет, сколько самолетов успеет вылететь за это время, если на взлетной полосе может быть только один самолет, а
Ответы (1)
Известно время вылета самолета: HH часов и ММ минут, а также продолжительность полета (НМ часов и МР минут). Напишите программу, которая определяет время прибытия самолета в аэропорт назначение ввиде "чч: мм"
Ответы (1)
Задача Полет Известно время вылета самолёта НН часов и ММ минут, а также продолжительность полёта (НР часов и МР минут) Напишите программу, которая определяет время прибытия самолёта в аэропорт Назначение в формате "чс: мм"
Ответы (1)
Решите в паскале ABC. Известно время полета вылета самолета - HH часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напечатать время прибытия самолета в аэропорт назначения в виде: самолет прибывает в 12.35.
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)