Задать вопрос
21 января, 23:35

Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём.

Формат входных данных

Вводится целое число n (100≤n≤999)

Формат выходных данных

Требуется вывести сумму и произведение его цифр через пробел.

+1
Ответы (1)
  1. 22 января, 01:57
    -1
    Можно сделать очень просто, введи каждую цифру данного трехзначного числа отдельно и совершай с ними все арифметические операции.

    Uses Crt;

    Var a, b, c, s, p:integer;

    Begin

    ClrScr;

    writeln ('Введи трехзначное число') ;

    readln (a, b, c) ; {После ввода каждой цифры жми Enter}

    s:=0; s:=a+b+c;

    p:=1; p:=a*b*c;

    writeln ('Сумма цифр s = ', s:5, 'Произведение цифр p = ', p:7) ;

    readkey

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)