Задать вопрос
15 марта, 14:42

Задача Полет

Известно время вылета самолёта НН часов и ММ минут, а также продолжительность полёта (НР часов и МР минут)

Напишите программу, которая определяет время прибытия самолёта в аэропорт Назначение в формате "чс: мм"

+2
Ответы (1)
  1. 15 марта, 17:20
    0
    Var

    h0, m0, h1, m1, h2, m2: integer;

    begin

    readln (h0, m0, h1, m1) ;

    m0 + = h0 * 60;

    m1 + = h1 * 60;

    m2 : = m0 + m1;

    h2 : = (m2 div 60) mod 24;

    m2 : = (m1 + m0) mod 60;

    h0 : = h2 div 10;

    h1 : = h2 mod 10;

    m0 : = m2 div 10;

    m1 : = m2 mod 10;

    write (h0, h1, ':', m0, m1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача Полет Известно время вылета самолёта НН часов и ММ минут, а также продолжительность полёта (НР часов и МР минут) Напишите программу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Известно время вылета самолета: HH часов и ММ минут, а также продолжительность полета (НМ часов и МР минут). Напишите программу, которая определяет время прибытия самолета в аэропорт назначение ввиде "чч: мм"
Ответы (1)
Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут).
Ответы (1)
Решите в паскале ABC. Известно время полета вылета самолета - HH часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напечатать время прибытия самолета в аэропорт назначения в виде: самолет прибывает в 12.35.
Ответы (1)
1) Представьте двоичное число 11011,11 в четырехбайтовом формате. Представьте число сначала в формате с плавающей запятой. 2) Представьте число 1110,101 в четырехбайтовом формате. Представьте число сначала в формате с плавающей запятой.
Ответы (1)
Представить положительное и отрицательное числа + 372 и - 372 в форматах В формате слово (2 байта) со знаком и фиксированной запятой. В формате двойное слово (4 байта) с плавающей запятой. В упакованном формате. В распакованном формате.
Ответы (1)