Задать вопрос
26 декабря, 11:42

Составьте программу, которая по введенному вами K - числу грибов печатает фразу, причем согласовывает окончание слова с числом K. Количество грибов может быть любым целым числом: 1, 3, 34, 127 и т. д. Окончание фразы определяется значением последней цифры.

+5
Ответы (1)
  1. 26 декабря, 14:26
    0
    Var g, i:integer;

    begin

    read (g) ;

    if (g=1) or ((g>20) and (g mod 10=1)) then begin writeln ('Мы нашли в лесу ', g,' гриб') ; i:=1; end;

    if ((g mod 10>1) and (g mod 1021) and (g mod 10>1) and (g mod 10<5)) then begin writeln ('Мы нашли в лесу ', g,' гриба') ; i:=1; end;

    if i=0 then writeln ('Мы нашли в лесу ', g,' грибов') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая по введенному вами K - числу грибов печатает фразу, причем согласовывает окончание слова с числом K. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Напишите программу, которая печатает все цифры заданного числа по одной в каждой строке начиная с последней цифры. в качестве входных данных допускается ваодить чтсла от 0 до 2 000 000 000
Ответы (1)
Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число не превышает 30 000.
Ответы (1)
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)
Дано натуральное число k. Написать программу, которая по введенному числу k от 1 до 99 напишет фразу: ("Мне, k, лет")
Ответы (1)