Задать вопрос
3 мая, 23:08

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.

Примеры работы программы:

Ввод: 3; Вывод: 3

Ввод: 2194; Вывод: 2

+2
Ответы (1)
  1. 4 мая, 02:29
    0
    Var a, af, al:integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    if a<10 then writeln ('Ответ: ', a)

    else

    if a<=99 then

    begin

    af:=a div 10;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end

    else

    if a<=999 then

    begin

    af:=a div 100;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end

    else

    if a<=9999 then

    begin

    af:=a div 1000;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end

    else

    if a<=30000 then

    begin

    af:=a div 10000;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Пример работы программы: Ввод: 5 5 5 Вывод: 0 0 0 Ввод: 5 8 5 Вывод: 8 8 8 Ввод: 5 6 7 Вывод: 5 6 7
Ответы (1)
Напишите программу, которая считывает с клавиатуры одно за другим два дробных числа, а затем строку. Если эта строка является обозначением одной из четырёх основных математических операций (+, -, * или /), то выведите результат применения этой
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Как это решать? И что тут вообще надо сделать? A+B Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Даны 2 числа a и b. Найти сумму этих чисел.
Ответы (1)