Задать вопрос
7 марта, 16:15

Напишите программу, которая печатает все цифры заданного числа по одной в каждой строке начиная с последней цифры. в качестве входных данных допускается ваодить чтсла от 0 до 2 000 000 000

+3
Ответы (1)
  1. 7 марта, 18:13
    0
    Var

    n: longint;

    begin

    readln (n) ;

    while n > 0 do

    begin

    writeln (n mod 10) ;

    n : = n div 10;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая печатает все цифры заданного числа по одной в каждой строке начиная с последней цифры. в качестве входных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Напишите программу печатающую на экране заданное число и четыре предыдущих нечетных числа. в качестве входных данных допускается задавать число от 10 до1000
Ответы (1)
Напишите программу, которая подсчитывает сумму всех цифр в данной строке. Например, в строке "Sochi-2014" сумма цифр равна 7. Формат входных данных Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.
Ответы (1)
Допускается ли соединение цифровой видеокамеры, поддерживающей интерфейс FireWire, с другим FireWire-устройством, минуя компьютер? Отметьте один правильный вариант ответа.
Ответы (1)
Формат входных данных В первой строке входных данных - два числа A и B (-10000
Ответы (1)