Задать вопрос
17 сентября, 13:37

составить программу нахождения максимального элемента в массиве из 30 чисел

+3
Ответы (1)
  1. 17 сентября, 16:52
    0
    Эта автоматически тебе всё сделает.

    Var i, n, max : Integer;

    a : array [1 ... 30] of Integer;

    begin

    for i : = 1 to 30 do

    begin

    Write ('a[', i, ']=') ;

    a[i]:=i+1;

    if max
    writeln (a[i]) ;

    end;

    writeln ('Максимальный элемент равен: ', max) ;

    end.

    Если нужно будет ввести последовательность с клавиатуры, то вот:

    Var i, n, max : Integer;

    a : array [1 ... 30] of Integer;

    begin

    for i : = 1 to 30 do

    begin

    Write ('a[', i, ']=') ;

    ReadLn (a[i]) ;

    if max
    end;

    writeln ('Максимальный элемент равен: ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу нахождения максимального элемента в массиве из 30 чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
составить программу на языке паскаль для нахождения максимального элемента в массиве из 7 элементов (целых двухзначный чисел) заданного случайным образом
Ответы (1)
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)