Задать вопрос
25 мая, 01:10

составить программу на языке паскаль для нахождения максимального элемента в массиве из 7 элементов (целых двухзначный чисел) заданного случайным образом

+1
Ответы (1)
  1. 25 мая, 01:18
    0
    uses crt;

    var a:array [1 ... 100] of integer;

    max, i, n:integer;

    begin

    randomize;

    for i:=1 to 7 do

    begin

    a[i]:=random (90) + 10;

    write (a[i],' ') ;

    end;

    writeln;

    max:=a[1];

    for i:=1 to n do

    if a[i]>max then max:=a[i];

    write ('max=', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу на языке паскаль для нахождения максимального элемента в массиве из 7 элементов (целых двухзначный чисел) заданного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
На Паскаль 1. С клавиатуры вводится число. Осуществить линейный поиск элемента в массиве. Вывести номер элемента, равного данному, либо сообщение о том, что такого элемента в массиве нет. 2.
Ответы (1)